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Introduction to Microsoft Access 2019
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What is a Database?

A database is a collection of information that is related. Access allows you to manage your information in
one database file. Within Access there are four major objects: Tables, Queries, Forms and Reports.

Tables store your data in your database
Queries ask questions about information stored in your tables
Forms allow you to view data stored in your tables

Reports allow you to print data based on queries/tables that you have created
Creating a Database

Start Access

Click on Blank database

N =

Access Search for online templates L

Suggested searches: Database Business Logs Industry Lists Personal Contacts

Recent

Pinned ’ ‘
Pin files you want to easily find later. Click N

the pin icon that appears when you hover )
over a file. 2]
i —|a8
Older
Database b

Desktop » merge
\ Blank database ‘ Asset tracking Contacts

Database1

3. Under File Name type a name for the database

4. To change the location of where to store the database, click the folder icon and select a location
5. Click Create

Blank database
File Mame
Database3

C\Users\fallivenep\Documents\,

Create

Access opens in a new table in Datasheet View.
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Understanding Views

There are multiple ways to view a database object. The two views for tables are Design View and

Datasheet View.

e Design View is used to set the data types, insert or delete fields, and set the Primary Key
e Datasheet View is used to enter and view the data for the records
Switching Between Design View and Datasheet View:
Click the View arrow on the Home tab and click on either Datasheet View or Design View

u? (] ; ABLE T access : Database- C\Users\fallivenep\Desktop\access.accdb (Access 2007 - 201 ?7 = & X
.i I. HOME CREATE EXTERNAL DATA DATABASE TOOLS FIELDS TABLE Pamela Joan Fallivene ~
b{' AB 12 c e [%% Date & Time ‘/, (I
V| Yes/No
View Short Number Currency . \ Validation
v Text 1 More Fields z
] \dd fDelete Propertie Formatting ! ~
Dat tV R
atasheet View I ] 3 Tablel 5
b/ ) 1D ~ Clickto Add ~
Design View y
= (New)

The Navigation Pane

The Navigation Pane is a list containing every object in your database. For easier viewing, the objects are

organized into groups by type.

Customers : Database- C:\Users\fallivenep\Documents\Cu:

File Home Create External Data Database Tools Help Fields Table Q Tell me what you want to do
b( AB 12 e Date & Time fy 88V
. V| Yes/No
View Short Number Currency _ Validation
= Text {=1/ More Fields ~ =
Views Add & Delete Properties Formatting Field Validation
. T3 Table1
All Access Objects ® « [ Teble
: ID ~ Click to Add ~
pearcr. Navigate To Category L * (New)
Tables 2
Custor
=T

¥ All Access Objects

To Minimize and Maximize the Navigation Pane:

Click the double arrow * in the upper-right corner of the Navigation Pane to minimize and maximize.
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Sorting the Objects in the Navigation Pane:
By default, objects are sorted by type, with the tables in one group, the forms in another, etc. However, you
can change how the objects are sorted.

Click the drop-down arrow to the right of the All Access Objects and click on a sort option from the list.

All Access O ’

Navigate To Category

ed Date

Filter By Group

v All Access Objects

Creating a Table
A table is a collection of data about a specific topic, such as employee information, products or customers.
The first step in creating a table is entering the fields and data types. This can be done in either Datasheet

View or Design View but it is recommended to set up the table in Design View.

Understanding Fields and Their Data Types
Field - an element of a table that contains a specific item of information, such as a last name.
Field’s Data Type - determines what kind of data the field can store.

Format Use to display

Text Short, alphanumeric values, such as a last name or a street address. Note,
beginning in Access 2013, Text data types have been renamed to Short Text.

Number, Numeric data

Large

Number

Date/Time Use to store date and time-based data

Currency Use to store monetary values

AutoNumber Use an AutoNumber field to provide a unique value that serves no other purpose
than to make each record unigue. The most common use for an AutoNumber field
is as a primary key, especially when no suitable natural key (a key that is based on
a data
field) is available.

Yes/No Yes and No values and fields that contain only one of two values

Rich Text Text or combinations of text and numbers that can be formatted using color and font
controls.

Calculated Results of a calculation. The calculation must refer to other fields in the same table.

Field You would use the Expression Builder to create the calculation.

Attachment Attached images, spreadsheet files, documents, charts, and other types of
supported files to the records in your database, similar to attaching files to e-mail
messages.

Hyperlink Use to store a hyperlink, such as an e-mail address or a Web site URL.

Format Use to display
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OLE Object

Use to attach an OLE Object, such as a Microsoft Office Excel spreadsheet, to a
record.

Memo

Long blocks of text. A typical use of a Memo field would be a detailed product
description.

Lookup

Displays either a list of values that is retrieved from a table or query, or a set of values
that you specified when you created the field. The Lookup Wizard starts and you can
create a Lookup field. The data type of a Lookup field is either text or number,
depending on the choices that you make in the wizard.

To Create a Table in Design View:

Click on Table

Click on the Create tab

Switch over to Design View on the Home tab

If prompted to save the table, enter a name and click on OK

Type the field names and select the appropriate data type for each field
Continue until all fields are added

Note: The order that you enter the field names is the order the fields will appear in the table.

Ed

FILE

E

View Primary
- Key
Views

HOME

Search...
Tables

E students

All Access ... &

TABLE TOOLS  access : Database- C\Users\fallivenep\Desktop\access.accdb (Access 2007 -
CREATE EXTERNAL DATA DATABASE TOOLS DESIGN
£E Insert Rows E F ﬁ\ D/EID ’ﬁ
5% Delete Rows s ]

Property Indexes Create Data Rename/
Sheet Macros = Delete Macro
Showy/Hide

Relationships Object
Dependencies

Relationships

ta Modify Lookups
Tools

© ‘j students

Field, Record & Table Events

Field Name Data Type

AutoNumber

Description (Optional)

/OLEp

Field Properties

General Lockup

Field Size
New Values
Format
Caption
Indexed
Text Align

Long Integer
Increment

Yes (Mo Duplicates)

General R
A field name

including space

Setting a Primary Key

The Primary Key is the unigue identifier for each record in a table. Access will not allow duplicate
entries in a primary key field. When creating a new table, Access automatically creates a field “ID” with
the AutoNumber data type, and assigns this as the Primary Key.

To Set a Primary Key:

Save the table

In Design View, position your cursor in the field you wish to set as the Primary Key
Click the Primary Key button on the toolbar

Note: To turn off the Primary Key simply click on the Primary Key button again.

June 2025
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$- -

Uamg Create External Data Database Tools Help Design Q Tell me what you want to do

[V €= Insert Rows g =) ==
* Delete Rows D

- i Object
Test Validation ol Modify Lookups Property Indexes Relationships j

Rules Sheet Dependencies

L ST Hos S Redfacorc SRt el Hesonts
Tables @ «
B Ais =
T3 inventory Field Name Data Type

AutoNumber

Title Short Text

Tracks Number

Wholesale Currency

Retail Currency

ArtistiD Number

Category Short Text

Input Masks
An input mask is used to pre-format a field to “look/act” a certain way when a user inputs data.

Examples: Social Security Number input mask automatically inserts the dashes; phone numbers
automatically inserts the parentheses and dashes.

The input mask data can either be stored in the table or simply displayed and not stored.
To Create an Input Mask for a Field:

1. In Design View, click in a field for which you’d like to apply an input mask

2. Inthe Field Properties section at the bottom of the screen, click in the Input Mask line and notice the
Build button that appears at the right end of the line (see below):

Field Properties

General Lookup

Field Size 50
Format

Input Mask

Caption

Default Value

Validation Rule
Validation Text

Required No

Allow Zero Length Yes
Indexed No
Unicode Compression Yes

IME Mode No Control
IME Sentence Mode None

Text Align General

3. Click the Build button to start the Input Mask Wizard (shown on next page).
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Input Mask Wizard

‘Which input mask matches how you want data to look?

To see how a selected mask works, use the Try It box.
To change the Input Mask list, click the Edit List button.

Input Mask: Data Look:

Phone Number (206)
f Social Security Number 831-8

1| »

Password | FEwEEss
Long Time 1:12:00 FM -

Try It: ‘

Select the appropriate input mask

Click Next

Click Next for additional screens on which you can set options for the input mask
Click Finish on the last screen of the input mask wizard

To Save the Table:

Click the Save icon on the toolbar

Enter a name for the table if you haven’t done so already

Click OK

Entering Data in a Table

In Datasheet View, start typing the data into the table by pressing the tab key to move to the next cell
When you have completed the record (row), press Enter

You can also click on the New record icon on the Home tab in the Records group

HOME = CREATE EXTERNALDATA DATABASETOOLS  FIELDS  TABLE

[\/‘ Y 8| Ascending Y Selection ~ oL > Totals Calibri (Detail) ~{11
%| Descending 17 Advanced ~— e Vv Spelling 2 GoTor B I U
View Filter Refresh i . R
Al - = More - ; Select~ A ~ L2~

Navigating in a Table
Use the arrows at the bottom of the table to navigate among records.

Record: 4 4 |2 of 2 ] Mo Filter Search

Sorting Records in a Table
Pasition your cursor in the field that you wish to sort by clicking on any record in the table
Click either the Sort Ascending or Sort Descending icon on the Home tab in the Sort & Filter group

June 2025 Microsoft Access 2019 (www.pcsdt.in)
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All~
Clipboard > Sort & Filter Record Find Text Formatting

HOME = CREATE  EXTERNAL® BAJABASE TOOLS  FIELDS  TABLE
[\/‘ Selection - 2 Totals Calibri (Detail) -1
Advanced ~ =~ Bsave V Spelling 2 GoTor B I U
View Refresh .. “
¥ - [ More ~ : Select~ A - B = =&

Queries
You use queries to view, change, and analyze data in different ways. You can also use them as a source of
records for forms and reports.

To Create a Query:

Click on the Create tab

Click on Query Design in the Queries group

Select the table that you would like to base your query on
Click Add

Repeat steps 3 and 4 until all tables are added

Close the Show Table window

The table(s) will now be displayed in the upper part of the Query Design Screen by boxes
containing the tables’ fields.

Double-click on the field names in the field list window which you would like to include in the query

'ﬁj Queryl
Attendance Courses Employees

* * * -
LogMNo % CourselD Last

SSN :~/£ Description First

CourselD Hours Department
Attended Prereq Title

Passed Cost ~_| Location -

Defining Criteriain the Query
In order to control which records are displayed, you must define criteria in a query. The most common type
of query is the Select Records query which will be discussed below.

To Define Criteria for Your Query:
Position your cursor in the criteria row in the field for which you wish to define the criteria for
Type the criteria

Example: To find all Excel courses:

Pasition your cursor in the criteria row of the Course ID field

June 2025 Microsoft Access 2019 (www.pcsdt.in) 8
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4. Type Excel (Access adds quotation marks to the criteria automatically when you tab to the next column)

Field: |First First CourselD Description Attended
Table: [Employees Employees Courses Courses Attendance
Sort:
Show: V] v (v V]
Criteria: Excel

'
Click the Run Query button *

5.
To Save the Query:
1. Click the Save icon
2. Enter a name for the query
3. Click OK
Creating a Form
A form is a database object that is used to enter or display data in a database.
To Create a Form:
1. Open the table or query on which you are basing the form
2. Click on the Create tab
3. Click on Form in the Forms group
A form is created and opens in Layout View.
Tables | =] Courses
Bl attendan ¥
[ courses s Access]
B emp Introduction to Access
Different Views:
Form View — this view allows you to view, create and edit records
Layout View - this view is similar to Design View but is more visually-oriented in that each control
displays real data. As a result, this is a very useful view for setting the size of controls, or performing
many other tasks that affect the visual appearance and usability of the form.
Design View - this view gives you a more detailed view of the structure of the form. You can see the
header, detail, and footer sections for the form. You cannot see the underlying data while you are
making design changes.
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Reports
Reports can be based on tables or queries.
To Create a Report:
1. Open the table or query on which you are basing the report
2. Click on the Create tab
3. Click on Report in the Reports
group A report is created in Layout View.
Different Views:
Print Preview — allows you see what the report would look like on a printed piece of paper Report

Tables

g Courses

B

Access!

1
2
L
omp1

xcell

xcellab

rontPage1

C
E
Excel2
E
F
»

rontPage2

IE1 Introduction to Internet Explorer 12 Internetl

View — allows you to see the data without having to display it in Print Preview Layout View — allows
you make design changes while browsing your data
Design View - gives you a more detailed view of the structure of your report

Printing Reports

To Print a Report:
1. Switch to Print Preview from View on the Design tab under Report Layout Tools
2. Click the Print icon
3. Click on OK

REPORT LAYOUT TOOLS

HOME CREATE EXTERNAL DATA DATABASE TOOLS DESIGN ARRANGE FORMAT PAGE SETUP

A | ) zv > Totals ~ N = 1~ — 1
‘ B RS labl] Ag [ & =L EE W/
grgup i Hide Details ¥ —3
ort
Themes Grouping & Totals Controls
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